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1 Product Overview
Ultra Station software is a PC software for the function/arbitrary waveform generator.
It is developed by RIGOL TECHNOLOGIES CO., LTD. (RIGOL) based on the RIGOL TAP
platform. The software can be used to edit the arbitrary waveform. It supports the
following products.

• DG1022Z, DG1032Z, DG1062Z

• DG2052, DG2072, DG2102

• DG4202, DG4162, DG4102, DG4062

• DG5071, DG5072, DG5101, DG5102, DG5251, DG5252, DG5351, DG5352

• DG5252 Pro, DG5254 Pro, DG5258 Pro, DG5352 Pro, DG5354 Pro, DG5358 Pro,
DG5502 Pro, DG5504 Pro, DG5508 Pro

• DG6052, DG6054, DG6102, DG6104

• DG70002, DG70004

• DG811, DG821, DG831, DG812, DG822, DG832

• DG821 Pro, DG822 Pro, DG852 Pro

• DG952, DG972, DG992

• DG902 Pro, DG912 Pro, DG922 Pro

• MSO5072, MSO5074, MSO5102, MSO5104, MSO5204, MSO5354, MSO5152-E

• MSO7014, MSO7024, MSO7034, MSO7054

• MSO8064, MSO8104, MSO8204

• MSO8074A, MSO8154A, MSO8304A

NOTE

For the MSO series, only those installed with the signal source option are supported by the

Ultra Station software.

1.1 Installation Environment
Hardware Configuration Requirements

• Internal Memory: 4 GB or higher (8 GB or higher is recommended.)

• Monitor: 1920x1080 screen resolution or higher.
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• Intel® Core™ i3 and above processor

• Hard disk: 1 GB or higher

Running Environment

• Microsoft Windows 7 SP1+, Windows 8, Windows 10, and Windows 11

• NI-VISA 5.4 or above

• Microsoft .NET 6.0 64-bit/32-bit

- 64-bit download link:https://dotnet.microsoft.com/en-us/download/

dotnet/thank-you/runtime-desktop-6.0.29-windows-x64-installer .

- 32-bit download link:https://dotnet.microsoft.com/en-us/download/

dotnet/thank-you/runtime-desktop-6.0.29-windows-x86-installer .

NOTE

If you want to install or run Microsoft .NET 6.0 on Microsoft Windows 7 SP1, additional

dependencies are required.

• Microsoft Visual C++ 2015-2019 Redistributable 64-bit/32-bit

- 64-bit download link:https://aka.ms/vs/17/release/vc_redist.x64.exe .

- 32-bit download link:https://aka.ms/vs/17/release/vc_redist.x86.exe .

• KB3063858 64-bit/32-bit

- 64-bit download link:https://www.microsoft.com/en-us/download/details.aspx?

id=47442 .

- 32-bit download link:https://www.microsoft.com/en-us/download/details.aspx?

id=47409 .

1.2 Installation and Uninstallation
Install Ultra Station

Double-click the "setup.exe" file of the Ultra Station software installation package to
complete the installation according to the installation wizard.

Uninstall Ultra Station

Click Start > Control Panel > Programs and Features > Ultra Station > Uninstall.
Then a prompt message is displayed, requesting you to confirm the operation. Click
Yes to start uninstalling the software.
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1.3 To Launch the Software
Click Start > RIGOL > Ultra Station to launch the software. You can also double-click
the software shortcut icon to launch the software.

1.4 Software Interface
The layout of the Ultra Station interface is shown below.

① ① 

② 

③

④ 

⑤ ⑥ 

⑦ 

Figure 1.1 Ultra Station Main Interface

1. Title bar. It displays the RIGOL logo, interface name, settings, help, minimize

window, maximize window, and close window button.

- Settings: Click on  to enter the setting interface. You can select the interface

language (Chinese/English) and the background color of the interface (Black/

White), as shown in the figure below.
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Figure 1.2 Interface Setting

- About: Click on  to display the software information.

Figure 1.3 Software Version Information

- Minimize window: Click on  to minimize the window.

- Maximize window: Click on  to maximize the window.

- Close: Click on  to close the window.

2. Menu display area. It displays the software menu, including File, Edit, Math, View,

and Send.

3. Sub-menu display area. It displays the sub-menus of the specified main menu,

such as Current Cursor, Edit Mode, Waveform Edit, and Draw Mode.
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4. Waveform segment display area. It displays the current waveform segment and

waveform coordinates information. Drag the scroll bar  or click on it to

display the waveforms in segments.

5. Waveform segment zoom area. It displays the zoomed area of the specified

waveform segment covered in green patch. Drag the green patch , and

the specified waveform segment covered by the green patch is displayed in the

waveform segment zoom area.

6. Waveform detailed information display area. It displays the detailed information of

the waveform.

Waveform Basic Info

- Points: indicate the number of points for the current waveform.

- Amplitude(V): indicates the amplitude of the original existing waveform.

- X-axis: indicates the type of the X-axis. It can be Point or Time.

- Sample Rate(Sa/s): indicates the sample rate of the current waveform.

Waveform Segments

- Start of Segment: indicates the start X-axis value of the specified waveform

segment. When dragging the scroll bar or clicking on the scroll bar  to
select the specified waveform segment, the value of "Start of Segment"
corresponds to the X-axis value of the specified waveform segment.

- Segment Length: indicates the number of points of each waveform segment.

- Start of Selection: indicates the start X-axis value of the specified waveform

segment covered by the green patch . When dragging the green patch

, dragging the scroll bar or clicking on the scroll bar , the value of
"Start of Selection" changes and corresponds to the X-axis value of the start
position of specified waveform segment covered by the green patch.

- End of Selection: indicates the end X-axis value of the specified waveform

segment covered by the green patch . When dragging the green patch

, dragging the scroll bar or clicking on the scroll bar , the value of
"End of Selection" changes and corresponds to the X-axis value of the end
position of specified waveform segment covered by the green patch.
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Current Mouse Position

- X Position: displays the X-axis position of the current mouse cursor.

- Y Position: displays the Y-axis position of the current mouse cursor.

XY Values at Current Cursor: displays the X values and Y values at Cursor X1

 and Cursor X2  respectively. Input a specified value into the input field

of X Value at Cursor X1 and X Value at Cursor X2,  and  will be
moved to the specified position.

- X Value at Cursor X1: displays the X-axis value of the crossing point between

the waveform and Cursor X1 . You can also input a value into the input
field of X Value at Cursor X1 to locate Cursor X1 to a specified position.

- Y Value at Cursor X1: displays the Y-axis value of the crossing point between

the waveform and Cursor X1 . You can also input a value into the input
field of Y Value at Cursor X1, and a new waveform point will be added to the
original waveform. Its Y-axis value is the Y value you set and X-axis value is

where the Cursor X1  resides.

- X Value at Cursor X2: displays the X-axis value of the crossing point between

the waveform and Cursor X2 . You can also input a value into the input

field of X Value at Cursor X2 to locate Cursor X2  to a specified position.

- Y Value at Cursor X2: displays the Y-axis value of the crossing point between

the waveform and Cursor X2 . You can also input a value into the input
field of Y Value at Cursor X2, and a new waveform point will be added to the
original waveform. Its Y-axis value is the Y value you set and X-axis value is

where the Cursor X2  resides.

Click on  to fold the detailed information display area. To show the details, click

on  or  to unfold the area.

7. Waveform files opened. It displays the currently opened waveform files. You can

click on the close icon of each file to close the existing file.
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2 To Use the Software
This manual introduces the Ultra Station software from the following parts: File
Management, To Create the Waveform, To Edit the Waveform, Waveform Calculation,
Waveform View, and To Send the Waveforms.

2.1 File Management
File management includes creating, opening, saving, or saving as a waveform file. You
can open the waveform files by clicking Recently to open the recent files or by
clicking Browse to select the file from the specified path and open it. You can also
close the file and exit the software.

Create a File

1. In Figure 1.1 , click File. The sub-menus of File are displayed at the left part of the
interface.

Figure 2.1 File Menu Interface

2. Click New, and then select a basic waveform from the built-in waveforms or click
"DC" to create a user-defined waveform (DC by default).

3. After selecting the specified waveform, you can set the waveform parameters such
as frequency, amplitude, and etc.

4. After confirming the settings, click OK, and the new waveform file is created.

NOTE
For details about creating a file of different types of waveforms, refer to To Create the
Waveform.

Open a File
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1. In Figure 2.1 , click Open to select the desired file from "Recently" or "Browse"
menu.

Figure 2.2 Open a File

2. Click Recently, and the recently saved waveform files are displayed at the right
section. Click to open the desired file.

3. Click Browse, and the default path is displayed. You can select the saved waveform
file from the specified path and open it.

NOTE
Ultra Station only supports opening waveform files saved with the "Ultra Station" save option

in the "Save As" menu. Besides, it also supports opening the saved waveform file suffixed with

"*.csv", and "*.bin" which are saved on some oscilloscopes (DHO series, MSO series, and

DS70000 series).

Save a File

1. After finishing editing the waveform, in Figure 1.1 , click File > Save.

2. Then the path location is displayed for you to choose. Select the desired path and
input the filename (if necessary), then click Save to save the file to the desired
path.

NOTE
Ultra Station supports saving the waveform as a file suffixed with "*.csv", "*.txt", "*.raf", and

"*.arb".

Save As

1. If you want to save the currently edited waveform file as a file with a specified
format or save it to the specified path, or save it as the file type that can be read,
click Save As in Figure 2.1 to save the current waveform as a file suffixed with a
specified format to a specified location.

 To Use the Software
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Figure 2.3 "Save As" Interface

2. You can save the file to the current path or history path. You can also click Browse
to select the desired path to save the file.

3. Besides, you can use the "Save Option" items to export the file and then import it
into the following products to load and output：

- DG1022Z, DG1032Z, DG1062Z

- DG2052, DG2072, DG2102

- DG4202, DG4162, DG4102, DG4062

- DG5071, DG5072, DG5101, DG5102, DG5251, DG5252, DG5351, DG5352

- DG5252 Pro, DG5254 Pro, DG5258 Pro, DG5352 Pro, DG5354 Pro, DG5358 Pro,
DG5502 Pro, DG5504 Pro, DG5508 Pro

- DG6052, DG6054, DG6102, DG6104

- DG70002, DG70004

- DG811, DG821, DG831, DG812, DG822, DG832

- DG821 Pro, DG822 Pro, DG852 Pro

- DG952, DG972, DG992

- DG902 Pro, DG912 Pro, DG922 Pro

Close

Click Close to close the file management interface and go back to the main interface
of the Ultra Station software.

Exit

Click Exit to exit the Ultra Station software.

 To Use the Software
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2.2 To Create the Waveform

1. In Figure 1.1 , click File > New. The available waveforms are displayed at the right

part of the menu.

Figure 2.4 Waveform Selection Interface

2. Select the desired waveform from the available built-in basic waveforms or create a

user-defined waveform file (DC). Then the waveform creation interface is displayed.

You can set the waveform parameters and preview the created waveform.

Figure 2.5 Waveform Creation Interface

3. Select the desired instrument and the waveform type.

a. Instrument: selects the desired instrument.

 To Use the Software
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b. Waveform: selects the desired waveform to be created from the drop-down

list. After selecting the desired waveform to be created, set its relevant

parameters.

For the parameter settings of the specified created waveform, refer to detailed
descriptions of the following waveform type.

- Sine

- Square

- Ramp

- Noise

- DC

- RS232

- Multi-Pulse

- Multi-Tone

4. After completing the parameters for the new waveforms, you can preview the

created waveform in the Preview section at the right part of the interface and

modify the relevant parameters in the Parameter section at the left part if

necessary.

5. After confirming the settings, click OK, and the new waveform is created.

2.2.1 Sine

In the "Create Waveform" interface, click the drop-down button of Waveform to
select Sine. The Sine waveform is displayed in the preview section. You can set the
parameters of Sine waveform at the left section of the current interface.
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Figure 2.6 Create the Sine Waveform

Points: sets the number of waveform points for the Sine waveform. It's an integer,
ranging from 8 to max. value (determined by the selected instrument model). You can
click the drop-down button of Points to select the desired points or directly input the
points for the Sine waveform of the specified instrument.

Amplitude: sets the amplitude of the created Sine waveform. Its range is from 0.02
Vpp to max. value (determined by the selected instrument model), accurate to two
decimal places.

Cycle: sets the number of cycles for the new Sine waveform. It's an integer, ranging
from 1 to (Points/8).

Sample Rate: sets the sample rate of the new Sine waveform. Its range is from 1,000
to max. value (determined by the selected instrument model).

Phase: sets the phase of the new Sine waveform. Its range is from 0º to 359.99º,
accurate to two decimal places.

2.2.2 Square

In the "Create Waveform" interface, click the drop-down button of Waveform to
select Square. The Square waveform is displayed in the preview section. You can set
the parameters of Square waveform at the left section of the current interface.

 To Use the Software
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Figure 2.7 Create the Square Waveform

Points: sets the number of waveform points for the Square waveform. It's an integer,
ranging from 8 to max. value (determined by the selected instrument model). You can
click the drop-down button of Points to select the desired points or directly input the
points for the Square waveform of the specified instrument.

Amplitude: sets the amplitude for the created Square waveform. Its range is from
0.02 Vpp to max. value (determined by the selected instrument model), accurate to
two decimal places.

Cycle: sets the number of cycles for the new Square waveform. It's an integer, ranging
from 1 to (Points/8).

Sample Rate: sets the sample rate of the new Square waveform. Its range is from
1,000 to max. value (determined by the selected instrument model).

Phase: sets the phase of the new Square waveform. Its range is from 0º to 359.99º,
accurate to two decimal places.

Duty Cycle: sets the duty cycle of the new Square waveform. It is defined as the
percentage that high level takes up in the whole period. Its range is from 20% to 80%.
By default, it is 50%.

2.2.3 Ramp

In the "Create Waveform" interface, click the drop-down button of Waveform to
select Ramp. The Ramp waveform is displayed in the preview section. You can set the
parameters of Ramp waveform at the left section of the current interface.
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Figure 2.8 Create the Ramp Waveform

Points: sets the number of waveform points for the Ramp waveform. It's an integer,
ranging from 8 to max. value (determined by the selected instrument model). You can
click the drop-down button of Points to select the desired points or directly input the
points for the Ramp waveform of the specified instrument.

Amplitude: sets the amplitude of the created Ramp waveform. Its range is from 0.02
Vpp to max. value (determined by the selected instrument model), accurate to two
decimal places.

Cycle: sets the number of cycles for the new Ramp waveform. It's an integer, ranging
from 1 to (Points/8).

Sample Rate: sets the sample rate of the new Ramp waveform. Its range is from 1,000
to max. value (determined by the selected instrument model).

Phase: sets the phase of the new Ramp waveform. Its range is from 0º to 359.99º,
accurate to two decimal places.

Symmetry: sets the symmetry of the Ramp waveform. It is defined as the percentage
that the rising period of the ramp takes up in the whole period. Its range is from 0%
to 100%.

2.2.4 Noise

In the "Create Waveform" interface, click the drop-down button of Waveform to
select Noise. The Noise waveform is displayed in the preview section. You can set the
parameters of the Noise waveform at the left section of the current interface.
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Figure 2.9 Create the Noise Waveform

Points: sets the number of waveform points for the Noise waveform. It's an integer,
ranging from 8 to max. value (determined by the selected instrument model). You can
click the drop-down button of Points to select the desired points or directly input the
points for the Noise waveform of the specified instrument.

Amplitude: sets the amplitude of the created Noise waveform. Its range is from 0.02
Vpp to max. value (determined by the selected instrument model), accurate to two
decimal places.

Sample Rate: sets the sample rate of the Noise waveform. Its range is from 1,000 to
max. value (determined by the selected instrument model).

2.2.5 DC

In the "Create Waveform" interface, click the drop-down button of Waveform to
select DC. The DC waveform is displayed in the preview section. You can set the
parameters of DC waveform at the left section of the current interface.

Figure 2.10 Create the DC Waveform

Points: sets the number of waveform points for the DC waveform. It's an integer,
ranging from 8 to max. value (determined by the selected instrument model). You can
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click the drop-down button of Points to select the desired points or directly input the
points for the DC waveform of the specified instrument.

Amplitude: sets the amplitude of the created DC waveform file. Its range is from 0.02
Vpp to max. value (determined by the selected instrument model), accurate to two
decimal places.

Sample Rate: sets the sample rate of the DC waveform. Its range is from 1,000 to
max. value (determined by the selected instrument model).

2.2.6 RS232

In the "Create Waveform" interface, click the drop-down button of Waveform to
select RS232. The RS232 waveform is displayed in the preview section. You can set
the parameters of RS232 waveform at the left section of the current interface.

Figure 2.11 Create the RS232 Waveform

Amplitude: sets the amplitude of the created RS232 waveform. Its range is from 0.02
Vpp to max. value (determined by the selected instrument model), accurate to two
decimal places.

Sample Rate: sets the sample rate of the created RS232 waveform. Its range is from
1,000 to max. value (determined by the selected instrument model).

Baud Rate: sets the baud rate of data transmission. It's an integer, ranging from 500
to (sample rate/2).

Data Bits: sets the number of data bits transmitted in RS232. It can be set to 5, 6, 7,
or 8.

Parity: set the parity of RS232 waveform to "Odd", "Even", or "None".

Stop Bits: sets the stop bits of RS232 waveform. It can be set to 1, 1.5, or 2.

Endian: sets the transmission sequence of RS232 waveform. It can be set to "LSB" and
"MSB". LSB (Least Significant Bit) indicates that the lowest bit of data is transmitted
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first; MSB (Most Significant Bit) indicates that the highest bit of data is transmitted
first.

Data: sets the data of the RS232 waveform. It is in Hex format, with "0x" being added
ahead of the Hex format.

2.2.7 Multi-Pulse

In the "Create Waveform" interface, click the drop-down button of Waveform to
select Multi-Pulse. The Multi-Pulse waveform is displayed in the preview section. You
can set the parameters of Multi-Pulse waveforms at the left section of the current
interface.

Figure 2.12 Create the Multi-Pulse Waveform

Amplitude: sets the amplitude of the new waveform. Its range is from 0.02 to max.
amplitude (determined by the selected instrument model), accurate to two decimal
places.

Sample Rate: sets the sample rate of the new multi-pulse waveform. Its range is from
1,000 to max. sample rate (determined by the selected instrument model).

Pulse Count: indicates the number of the pulses contained for the new multi-pulse
waveforms. It's an integer, ranging from 2 to 30.

Delay Time: indicates the time interval between the pulses. It ranges from 0 to 1 s,
accurate to 9 decimal places.

Pulse Index: specifies the pulse number. You can select the specified pulse for the
parameter setting.

HPulse Width: indicates the high-level pulse width. When a specified pulse number is
selected, set it for the specified pulse. The min. value is 1/sample rate (expressed in s).
The sum of the HPulse width and LPulse width of all the pulses shall not be greater
than (max. waveform points/sample rate (expressed in s)), accurate to 9 decimal
places. The max. number of the waveform points is determined by the currently
selected instrument model.
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LPulse Width: indicates the low-level pulse width. When a specified pulse number is
selected, set it for the specified pulse. The min. value is 1/sample rate (expressed in s).
The sum of the HPulse width and LPulse width of all the pulses shall not be greater
than (max. waveform points/sample rate (expressed in s)), accurate to 9 decimal
places. The max. number of the waveform points is determined by the currently
selected instrument model.

2.2.8 Multi-Tone

In the "Create Waveform" interface, click the drop-down button of Waveform to
select Multi-Tone. The multi-tone waveform is displayed in the preview section. You
can set the parameters of multi-tone waveform at the left section of the current
interface.

Figure 2.13 Create the Multi-Tone Waveform

Points: sets the number of waveform points of the new multi-tone waveform. It is an
integer, ranging from 8 to max. points (determined by the selected instrument
model). You can click the drop-down button of Points to select the desired points or
directly input the points for the multi-tone waveform of the specified instrument.

Amplitude: sets the amplitude of the new multi-tone waveform. Its range is from 0.02
to max. amplitude (determined by the selected instrument model), accurate to two
decimal places.

Sample Rate: sets the sample rate of the new multi-tone waveform. Its range is from
1,000 to max. sample rate (determined by the selected instrument model).

Reference Amp: indicates the amplitude of each sine waveform (with 0 dB gain) of
the multi-tone waveform.

Start Freq: indicates the start frequency of the new multi-tone waveform. Its range is
from 400 to sample rate/2.5, accurate to 6 decimal places.

Tone Spacing: indicates the spacing between the adjacent frequencies of the new
multi-tone signal. Its range is from 1,000 to 50 M.
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Tone Count: indicates the number of the tones. It's an integer, ranging from 1 to 30.

Tone Index: specifies the tone number. You can select the specified tone for the
parameter setting.

Gain: specifies the magnification times for the selected tone. Its range is from 0 to
-20 dB.

Phase: indicates the start phase (start point of the waveform) of the selected tone.
The default unit is degree (°). Its range is from 0° to 359.99°, accurate to two decimal
places.

Status: sets the status of the selected tone. 0 indicates that the selected tone is
invalid; 1 indicates that the selected tone is valid.

2.3 To Edit the Waveform
Ultra Station allows you to cut, copy, paste, delete, mirror, invert, insert, and overwrite
waveforms. It supports point, free, and line drawing of waveforms.

2.3.1 Cursor

Cursor Position

Click on  to activate Cursor 1 (X1, in blue); click on  to activate Cursor 2
(X2, in green). When the cursor is selected, the selected cursor turns out to be a solid
line whereas the not selected one becomes a dotted line. Select the cursor and drag it
to any position.

The waveforms specified by Cursor 1 (X1) and Cursor 2 (X2) are the currently selected
waveforms.

2.3.2 Edit Mode

Ultra Station provides two waveform editing modes: Insert  and Overwrite

.

Insert: Inserts the preset or copied waveform at the earlier cursor position, and shifts
the original waveform to the right by the length of the preset or copied waveform.

Overwrite: Inserts the preset or copied waveform at the earlier cursor position, and
overwrites the original waveform according to the length of the preset or copied
waveform.
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2.3.3 Wave Edit

Click Edit, and the sub-menus are displayed. Refer to File Management to open the
waveforms to be edited.

Figure 2.14 Waveform Editing Interface

Copy and Paste the Waveform

1. Click on  to enter the waveform insertion mode. Click on  to

enter the waveform overwriting mode.

2. Move the current cursor  and  to specify the waveform segment to be

copied.

3. Click on  to copy the specified segment of the waveform.

4. Move the cursor  or  to specify the desired position where you want to

paste the waveform. Click on  to paste the copied specified waveform to this
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position. The copied waveform will be pasted to the location specified by X1 and

X2 in Insert edit mode. The original waveform in the range specified by X1 and X2

will be moved towards right. In Overwrite edit mode, the copied waveform will be

pasted to overwrite the original waveform located between X1 and X2.

5. After completing the operation, click File > Save (or Save As) to save the current

operation and save it to a desired location as a file.

Cut and Paste the Waveform

1. Click on  to enter the waveform insertion mode. Click on  to

enter the waveform overwriting mode.

2. Move the current cursor  and  to specify the range of the selected

waveform to be cut.

3. Click on  to cut the selected waveform segment.

4. Move the current cursor  and  to the desired position where you want

to paste the waveform. Click on  to paste the specified waveform to this

position. The cut waveform will be pasted to the location specified by X1 and X2 in

Insert edit mode. The original waveform in the range specified by X1 and X2 will

be moved towards right. In Overwrite edit mode, the cut waveform will be pasted

to overwrite the original waveform located between X1 and X2.

5. After completing the operation, click File > Save (or Save As) to save the current

operation and save it to a desired location as a file.
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Delete the Waveform

1. Move the current cursor  and  to specify the range of the waveform to

be deleted.

2. Click on  to delete the specified segment of the waveform. When deleted in

"Insert" mode, the right side becomes a blank waveform. When deleted in

"Overwrite" mode, the deleted segment becomes a blank waveform.

3. After completing the operation, click File > Save (or Save As) to save the current

operation and save it to a desired location as a file.

Mirror the Waveform

1. Move the current cursor  and  to specify the range of the selected

waveform to be mirrored.

2. Click on  to mirror the specified segment of the waveform. The selected

waveform will make a symmetry along the center of the vertical axis.

3. After completing the operation, click File > Save (or Save As) to save the current

operation and save it to a desired location as a file.

Invert the Waveform

1. Move the current cursor  and  to specify the range of the selected

waveform to be inverted.

2. Click on  to invert the specified segment of the waveform. The selected

waveform will be inverted along the center of the horizontal axis.
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3. After completing the operation, click File > Save (or Save As) to save the current

operation and save it to a desired location as a file.

Insert the Waveform

1. In Figure 2.14 , select "Insert" mode and then click  to insert the

desired waveform into the range specified by X1 and X2.

Figure 2.15 "Insert Waveform" Interface

2. Waveform: selects the desired waveform to be inserted from the drop-down list of

Waveform.

3. Parameters: sets the parameters of the inserted waveform. The available

waveforms to be inserted include the following. Click on the specified topic below

to learn more about parameter settings for the specified waveform type.

- To Insert the Sine Waveform

- To Insert the Square Waveform

- To Insert the Ramp Waveform
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- To Insert the Noise Waveform

- To Insert the DC Signal Waveform

- To Insert the RS232 Waveform

- To Insert the Multi-Pulse Waveform

- To Insert the Multi-Tone Waveform

4. Preview: displays the preview of waveforms to be inserted.

5. After completing the settings, click OK and the system will insert this waveform at

the smaller cursor position, while the original waveform at that position will be

moved towards right in sequence.

6. After completing the operation, click File > Save (or Save As) to save the current

operation and save it to a desired location as a file.

Overwrite the Waveform

1. In Figure 2.14 , select "Overwrite" mode and then click  to insert the

desired waveform into the range specified by X1 and X2 to overwrite the original

waveform, as shown in Figure 2.15 .

2. Waveform: selects the desired waveform to overwrite the original waveform from

the drop-down list of Waveform.

3. Parameters: sets the parameters of the inserted waveform.

For detailed parameter settings, refer to relevant descriptions in "Insert the
Waveform" section above.

4. Preview: displays the preview of waveforms to be inserted to overwrite the

original waveform.

5. After completing the settings, click OK, then the system will use this waveform to

overwrite the waveform of the same length starting from the smaller cursor

position.

6. After completing the operation, click File > Save (or Save As) to save the current

operation and save it to a desired location.
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Undo Operation

Click on  to undo the last operations. At most, last five operations can be
undone.

Redo Operation

Click on  to redo the last undo operations. At most, last five undo operations
can be recovered.

2.3.3.1 To Insert the Sine Waveform

In the "Insert Waveform" interface, click the drop-down button of Waveform to
select Sine. The Sine waveform is displayed in the preview section. You can set the
parameters of Sine waveform at the left section of the current interface.

Figure 2.16 Insert the Sine Waveform

Points: sets the number of waveform points for the inserted Sine waveform. The
range is from 1 to the max. number of the original existing waveform points. You can
click the drop-down button of Points to select the desired points or directly input
the points for the inserted Sine waveform of the specified instrument.

To End: When you check the checkbox of "To End", the input field of Points is
automatically filled with the number of waveform points from the smaller cursor
position to the waveform end.

Amplitude: sets the amplitude of the inserted Sine waveform. Its range is from 0.02
Vpp to the amplitude of the original existing waveform, no more than two decimal
places.

Offset: sets the DC offset for the inserted Sine waveform. Its range is related to the
amplitude setting of the inserted waveform and the amplitude of the original
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existing waveform. Its value ranges from -(amplitude of the original existing
waveform - currently set amplitude of the inserted waveform)/2 to +(amplitude of
the original existing waveform - currently set amplitude of the inserted waveform)/2,
no more than two decimal places.

Cycle: sets the number of cycles for the inserted Sine waveform. It's an integer,
ranging from 1 to (Points/8).

Sample Rate: same as the sample rate of the original existing waveform and cannot
be modified.

Phase: sets the phase of the inserted Sine waveform. Its range is from 0º to 359.99º,
accurate to two decimal places.

2.3.3.2 To Insert the Square Waveform

In the "Insert Waveform" interface, click the drop-down button of Waveform to
select Square. The Square waveform to be inserted is displayed in the preview
section. You can set the parameters of Square waveform at the left section of the
current interface.

Figure 2.17 Insert the Square Waveform

Points: sets the number of waveform points for the inserted Square waveform. The
range is from 1 to the max. number of the original existing waveform points. You can
click the drop-down button of Points to select the desired points or directly input
the points for the inserted Square waveform of the specified instrument.

To End: When you check the checkbox of "To End", the input field of Points is
automatically filled with the number of waveform points from the smaller cursor
position to the waveform end.

Amplitude: sets the amplitude of the inserted Square waveform. Its range is from
0.02 Vpp to the amplitude of the original existing waveform, no more than two
decimal places.
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Offset: sets the DC offset for the inserted Square waveform. Its range is related to
the amplitude setting of the inserted waveform and the amplitude of the original
existing waveform. Its value ranges from -(amplitude of the original existing
waveform - currently set amplitude of the inserted waveform)/2 to +(amplitude of
the original existing waveform - currently set amplitude of the inserted waveform)/2,
no more than two decimal places.

Cycle: sets the number of cycles for the inserted Square waveform. It's an integer,
ranging from 1 to (Points/8).

Sample Rate: same as the sample rate of the original existing waveform and cannot
be modified.

Phase: sets the phase of the inserted Square waveform. Its range is from 0º to
359.99º, accurate to two decimal places.

Duty Cycle: sets the duty cycle of the inserted Square waveform. It is defined as the
percentage that high level takes up in the whole period. Its range is from 20% to
80%. By default, it is 50%.

2.3.3.3 To Insert the Ramp Waveform

In the "Insert Waveform" interface, click the drop-down button of Waveform to
select Ramp. The Ramp waveform is displayed in the preview section. You can set
the parameters of Ramp waveform at the left section of the current interface.

Figure 2.18 Insert the Ramp Waveform

Points: sets the number of waveform points for the inserted Ramp waveform. The
range is from 1 to the max. number of the original existing waveform points. You can
click the drop-down button of Points to select the desired points or directly input
the points for the inserted Ramp waveform of the specified instrument.

To End: When you check the checkbox of "To End", the input field of Points is
automatically filled with the number of waveform points from the smaller cursor
position to the waveform end.
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Amplitude: sets the amplitude of the inserted Ramp waveform. Its range is from
0.02 Vpp to the amplitude of the original existing waveform.

Offset: sets the DC offset for the inserted Ramp waveform. Its range is related to the
amplitude setting of the inserted waveform and the amplitude of the original
existing waveform. Its value ranges from -(amplitude of the original existing
waveform - currently set amplitude of the inserted waveform)/2 to +(amplitude of
the original existing waveform - currently set amplitude of the inserted waveform)/2.

Cycle: sets the number of cycles for the inserted Ramp waveform. It's an integer,
ranging from 1 to (Points/8).

Sample Rate: same as the sample rate of the original existing waveform and cannot
be modified.

Phase: sets the phase of the inserted Ramp waveform. Its range is from 0º to
359.99º, accurate to two decimal places.

Symmetry: sets the symmetry of the inserted Ramp waveform. It is defined as the
percentage that the rising period of the ramp takes up in the whole period. Its range
is from 0% to 100%.

2.3.3.4 To Insert the Noise Waveform

In the "Insert Waveform" interface, click the drop-down button of Waveform to
select Noise. The Noise waveform is displayed in the preview section. You can set
the parameters of the Noise waveform at the left section of the current interface.

Figure 2.19 Insert the Noise Waveform

Points: sets the number of waveform points for the inserted Noise waveform. The
range is from 1 to the max. number of the original existing waveform points. You can
click the drop-down button of Points to select the desired points or directly input
the points for the inserted Noise waveform of the specified instrument.

To End: When you check the checkbox of "To End", the input field of Points is
automatically filled with the number of waveform points from the smaller cursor
position to the waveform end.
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Amplitude: sets the amplitude of the inserted Noise waveform. Its range is from
0.02 Vpp to the amplitude of the original existing waveform.

Offset: sets the DC offset for the inserted Noise waveform. Its range is related to the
amplitude setting of the inserted waveform and the amplitude of the original
existing waveform. Its value ranges from -(amplitude of the original existing
waveform - currently set amplitude of the inserted waveform)/2 to +(amplitude of
the original existing waveform - currently set amplitude of the inserted waveform)/2.

Sample Rate: same as the sample rate of the original existing waveform and cannot
be modified.

2.3.3.5 To Insert the DC Signal Waveform

In the "Insert Waveform" interface, click the drop-down button of Waveform to
select DC. The DC signal waveform is displayed in the preview section. You can set
the parameters of DC signal waveform at the left section of the current interface.

Figure 2.20 Insert the DC Signal Waveform

Points: sets the number of waveform points for the inserted DC waveform. The
range is from 1 to the max. number of the original existing waveform points. You can
click the drop-down button of Points to select the desired points or directly input
the points for the inserted DC waveform of the specified instrument.

To End: When you check the checkbox of "To End", the input field of Points is
automatically filled with the number of points from the smaller cursor position to the
waveform end.

Offset: sets the DC offset for the inserted DC signal waveform. Its range is related to
the amplitude setting of the inserted waveform and the amplitude of the original
existing waveform. Its value ranges from -(amplitude of the original existing
waveform - currently set amplitude of the inserted waveform)/2 to +(amplitude of
the original existing waveform - currently set amplitude of the inserted waveform)/2.

Sample Rate: same as the sample rate of the original existing waveform and cannot
be modified.
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2.3.3.6 To Insert the RS232 Waveform

In the "Insert Waveform" interface, click the drop-down button of Waveform to
select RS232. The RS232 waveform is displayed in the preview section. You can set
the parameters of RS232 waveform at the left section of the current interface.

Figure 2.21 Insert the RS232 Waveform

Amplitude: sets the amplitude of the inserted RS232 waveform. Its range is from
0.02 Vpp to the amplitude of the original existing waveform.

Offset: sets the DC offset for the inserted RS232 waveform. Its range is related to the
amplitude setting of the inserted waveform and the amplitude of the original
existing waveform. Its value ranges from -(amplitude of the original existing
waveform - currently set amplitude of the inserted waveform)/2 to +(amplitude of
the original existing waveform - currently set amplitude of the inserted waveform)/2.

Sample Rate: same as the sample rate of the original existing waveform and cannot
be modified.

Baud Rate: sets the baud rate of data transmission.

Data Bits: sets the number of data bits transmitted in RS232. It can be set to 5, 6, 7,
or 8.

Parity: sets the parity of RS232 waveform to "Odd", "Even", or "None".

Stop Bits: sets the stop bits of RS232 waveform. It can be set to 1, 1.5, or 2.

Endian: sets the transmission sequence of RS232 waveform. It can be set to "LSB"
and "MSB". LSB (Least Significant Bit) indicates that the lowest bit of data is
transmitted first; MSB (Most Significant Bit) indicates that the highest bit of data is
transmitted first.

Data: sets the data of RS232 waveform.
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2.3.3.7 To Insert the Multi-Pulse Waveform

In the "Insert Waveform" interface, click the drop-down button of Waveform to
select Multi-Pulse. The Multi-Pulse waveform is displayed in the preview section.
You can set the parameters of Multi-Pulse waveforms at the left section of the
current interface.

Figure 2.22 Insert the Multi-Pulse Waveform

Amplitude: sets the amplitude of the multi-pulse waveform. Its range is from 0.02
Vpp to the amplitude of the current existing waveform.

Offset: sets the offset for the inserted multi-pulse waveform. Its range is related to
the amplitude setting of the inserted waveform and the amplitude of the original
existing waveform. Its value ranges from -(amplitude of the original existing
waveform - currently set amplitude of the inserted waveform)/2 to +(amplitude of
the original existing waveform - currently set amplitude of the inserted waveform)/2.

Sample Rate: same as the sample rate of the original waveform and cannot be
modified.

Pulse Count: indicates the number of the pulses. It's an integer, ranging from 2 to
30.

Delay Time: indicates the time interval between the pulses. It ranges from 0 to 1 s,
accurate to 9 decimal places.

Pulse Index: specifies the pulse number. You can select the specified pulse for the
parameter setting.

HPulse Width: indicates the high-level pulse width. When a specified pulse number
is selected, set it for the specified pulse. The min. value is 1/sample rate (expressed
in s). The sum of the HPulse width and LPulse width of all the pulses shall not be
greater than (max. waveform points/sample rate (expressed in s)), accurate to 9
decimal places.

LPulse Width: indicates the low-level pulse width. When a specified pulse number is
selected, set it for the specified pulse. The min. value is 1/sample rate (expressed in
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s). The sum of the HPulse width and LPulse width of all the pulses shall not be
greater than (max. waveform points/sample rate (expressed in s)), accurate to 9
decimal places.

2.3.3.8 To Insert the Multi-Tone Waveform

In the "Insert Waveform" interface, click the drop-down button of Waveform to
select Multi-Tone. The multi-tone waveform is displayed in the preview section. You
can set the parameters of multi-tone waveform at the left section of the current
interface.

Figure 2.23 Insert the Multi-Tone Waveform

Points: sets the number of waveform points for the inserted multi-tone waveform.
The range is from 1 to the max. number of the original existing waveform points. You
can click the drop-down button of Points to select the desired points or directly
input the points for the inserted multi-tone waveform of the specified instrument.

To End: When you check the checkbox of "To End", the input field of Points is
automatically filled with the number of waveform points from the smaller cursor
position to the waveform end.

Amplitude: sets the amplitude of the inserted multi-tone waveform. Its range is
from 0.02 Vpp to the amplitude set for the current existing waveform.

Offset: sets the offset for the inserted multi-tone waveform. Its range is related to
the amplitude setting of the inserted waveform and the amplitude of the original
existing waveform. Its value ranges from -(amplitude of the original existing
waveform - currently set amplitude of the inserted waveform)/2 to +(amplitude of
the original existing waveform - currently set amplitude of the inserted waveform)/2.

Sample Rate: same as the sample rate of the original waveform and cannot be
modified.
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Reference Amp: indicates the amplitude of each sine waveform (with 0 dB gain) of
the inserted multi-tone waveform.

Start Freq: Indicates the start frequency of the inserted multi-tone waveform. Its
range is from 400 to sample rate/2.

Tone Spacing: Indicates the spacing between the adjacent frequencies of the
inserted multi-tone signal. Its range is from 1,000 to 50M.

Tone Count: indicates the number of the tones. It's an integer, ranging from 1 to 30.

Tone Index: specifies the tone number. You can select the specified tone for the
parameter setting.

Gain: specifies the magnification times for the selected tone. Its range is from 0 to
-20 dB.

Phase: indicates the start phase (start point of the waveform) of the selected tone.
The default unit is degree (°). Its range is from 0° to 359.99°, accurate to two decimal
places.

Status: sets the status of the selected tone. 0 indicates that the selected tone is
invalid; 1 indicates that the selected tone is valid.

2.3.4 Waveform Drawing Mode

Point Drawing

1. In Figure 2.14 , click on  to start point drawing.

2. In the waveform editing area, click any place to leave points one by one, and the
points will be connected together with the existing waveform to form the new
waveform shape.

All the added points can be seen as green dots in the waveform editing area.

3. Click on  to clear all the green dots that you have drawn.

Free Drawing

1. In Figure 2.14 , click on  to start free drawing.

2. Click any place of the waveform editing area and long press the left key of the

mouse to drag the existing waveform to perform waveform drawing. Drag to any
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place to make a free drawing. The new drawn segment will be linked with the

existing waveform.

Line Drawing

1. In Figure 2.14 , click on  to start line drawing.

2. Click any place of the waveform editing area to set the starting point of the line.

Then click again to set the end point. A straight line will be drawn between the

starting point and the end point. Move the mouse and click again to set the end

point of the next segment. You can continue moving and clicking the mouse to

draw multiple connected line segments.

2.4 Waveform Calculation
In Figure 1.1 , click Math, and the sub-menus of the math setting are displayed under
the Math menu. Click FormulaEdit, and then the Formula Editor interface is
displayed.

①
②

③ ⑤

④

Figure 2.24 Formula Editor Interface

• ①: displays the interface name and the close button.

• ②: previews the formula you are editing or have edited.

• ③: displays the formula command. You can select the desired formula and input

the number, operator, and function required for the formula. If you click "00",
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two zeros will be input. "n" represents the index of waveform points, ranging

from 0 to the specified end point. "E" indicates scientific notation.

Figure 2.25 Trigonometic/Antitrigonometric/Hyperbolic Functions

- sin: Sine function.

- cos: Cosine function.

- tan: Tangent function. It is abbreviated as tan or tg.

- csc: Cosecant function. It is abbreviated as csc or cosec.

- sec: Secant function.

- cot: Cotangent function. It is abbreviated as cot or ctg.

- asin: Arc sine function.

- acos: Arc cosine function.

- atan: Arc tangent function.

- sinh: Hyperbolic sine function.

- cosh: Hyperbolic cosine function.

- tanh: Hyperbolic tangent function.

 To Use the Software

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. Ultra Station User Guide

35



Figure 2.26 Math Function

- ^: Power function. For example, n^3 indicates the 3rd power of n.

- sqrt: Square root.

- exp: Base-e exponential function.

- log: Base-10 logarithm function.

- log2: Base-2 logarithm function.

- ln: Base-e logarithm function.

- int: integer truncation function. int(x) means directly discarding the

fractional part of x.

- ceil: Rounds up to the nearest integer. The formula ceil(x) generates the

smallest integral value that is greater than or equal to the specified decimal

number.

- floor: Rounds down to the nearest integer. The formula ceil(x) generates

the largest integral value that is equal to or smaller than the specified

decimal number.

- abs: Absolute value.

- sign: Sign function. The formula sign(x) returns a number that indicates the

sign of x. When x>0, sign(x) = 1; when x<0, sign(x) = -1; when x = 0, sign(x)

= 0.

• ④: parameter setting area. You can set the waveform points.
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- Points: sets the number of waveform points specified between X1 and X2

for the waveform operation. The range is from 0 to the number of

waveform points specified between X1 and X2.

- To End: When you check the checkbox of "To End", the input field of Points

is automatically filled with the max. number of waveform points specified

between X1 and X2.

- Time: displays the X-axis value of the waveforms when the X-axis of the

waveform is set to Time. It changes along with the value of Points

automatically and cannot be set manually.

• ⑤: waveform preview area. In the formula command area, after setting the

formula, click Compile to compile the formula. Then set the parameter. After

that, you can preview the waveforms in the waveform preview area.

Click OK to confirm the settings.

Multiply/Add/Subtract

In Figure 1.1 , click Math, and the sub-menus of the math operation are displayed
under the Math menu. Click on the specified math operator icon to enter the
corresponding math operation interface.

The following section takes multiplication operation interface as an example to
illustrate the function of each part.

①

②

③

④ ⑤

Figure 2.27 Multiplication Operation

• ①: displays the interface name and the close button.

• ②: displays the current waveform setting and waveform preview.
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• ③: displays the current operation type. Click the drop-down button of the

operation type to select the desired type.

• ④: displays the operation waveform setting and waveform preview. You can

select the desired waveform from the drop-down list of Select as the operation

waveform.

- DC: A DC waveform with 0 offset.

- Standard Waveform: You can define a waveform via the pop-up "Create

Waveform" menu.

- Waveform Copy: The clipboard stores waveforms previously saved through

Copy or Cut operations. If no copy or cut operation has been performed

yet, the default is a DC waveform with 0 offset.

• ⑤: displays the output waveform setting and preview of the waveforms that

have undergone the specified math operation.

After setting, click OK to confirm the calculation.

Similarly, waveform addition and subtraction operations can be performed.

2.5 Waveform View
In Figure 1.1 , click View, and the sub-menus of the view setting are displayed under
the View menu.
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Figure 2.28 Waveform View Setting Interface

Click on  to select whether to show or hide the waveform line. Click on

 to show the line; click on  to hide the line.

Click on  to set the type of the X-axis. When  is selected, X-

axis represents the number of points. When  is selected, X-axis represents
time.

Click on  to select whether to show or hide the grids. When  is

selected, the grids are shown in the background. When  is selected, the
grids are hidden.

Click on  and hold on to the left key of the mouse to drag the mouse

cursor to select the specified waveform area to be enlarged. Click on  to
restore the selected waveform to its original size.
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Click on  to zoom in the waveforms. Click on  to zoom out. Click

on  to restore it to its original size. You can also roll the mouse wheel to
zoom in or out the selected waveform.

2.6 To Send the Waveform
In Figure 1.1 , click Send, and the sub-menu of the Send menu is displayed. Click

, and the "Send Waveform Data" interface is displayed.

①

②

③

④

⑤

⑥

Figure 2.29 "Send Waveform Data" Interface

• ①: displays the interface name and the close button.

• ②: displays the current waveform parameter settings.

• ③: displays the waveform preview.

• ④: instrument selection area.

Click Add to enter the Add Instrument interface. You can add the LAN
instrument.
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Figure 2.30 Add LAN Instrument

- IP Address: inputs the IP address of the instrument manually to which the

waveform data are sent.

- TCPIP ID: selects the TCPIP ID.

- Communication Protocol: selects one of the three communication

protocols: VXI, HiSLIP, and Socket. When you select "VXI" or "HiSLIP", you

need to set Remote Name. When you select "Socket", you need to set the

port number.

- After setting, click Test Connection to check whether the instrument is

successfully connected. If yes, click OK, then the instrument is added to the

LAN instrument resource list. If no, please check whether the IP address of

the instrument that you input is correct.

• ⑤: instrument parameter area. It displays the selected channel, enables or

disables the output, the location where the waveform data are sent to.

• ⑥: operation confirmation area. After completing the settings, click OK to

confirm the setting operation. Click Cancel to cancel the setting operation.
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